NFTAC website home page or NFTAC Photo Gallery or NFTAC Club Blog
Subscribe in a reader
Join or renew today and receive a free t-shirt or tech CD, see details in the join the club section at www.firebirdtaclub.com!

Author Topic: Elusive Engine Problem - shuts down when warm  (Read 3347 times)

0 Members and 1 Guest are viewing this topic.

seamusmac

  • Message Board Member but not a NFTAC Club Member
  • *
  • Posts: 1
Elusive Engine Problem - shuts down when warm
« on: March 14, 2007, 11:39:09 AM »
My 76 T/A (SoCal based) shuts down consistently after about 20-25 mins of running and then every few minutes or so thereafter.  Shuts off clean, no sputtering just like someone shut the ignition off.  Then fires right back up immediately when I park it and flip the ignition.  Feels electrical related.  Mechanic is stumped. Thoughts?  New battery and module did not fix.  Also recently replaced fuel pump. Welcome any thoughts.  Getting it ready to sell soon.  Nice shape otherwise.
« Last Edit: March 14, 2007, 12:17:20 PM by firebirdclub »

miketransamkid

  • Message Board Member not current NFTAC Club Member
  • **
  • Posts: 13
Re: Elusive Engine Problem - shuts down when warm
« Reply #1 on: June 19, 2007, 11:25:30 AM »
look at the wires going to the pick-up coil underneathe the distributor rotor. Or check the coil. My Old mans grand prix used to cut out on him randomly. It was the wires on the pick up coil. My car quit on me one time going out to dinner. Pulled into a parking spot reaching for the ignition to shut it off. It shut off before i could touch the keys. No refire. coil took a leave of absence.

National Firebird and Trans Am Club Message Board

Re: Elusive Engine Problem - shuts down when warm
« Reply #1 on: June 19, 2007, 11:25:30 AM »


 

NFTAC website home page or NFTAC Photo Gallery or NFTAC Club Blog