NFTAC website home page or NFTAC Photo Gallery or NFTAC Club Blog
Subscribe in a reader
Join or renew today and receive a free t-shirt or tech CD, see details in the join the club section at www.firebirdtaclub.com!

Author Topic: Couple of WEIRD problems 1984 WS6 Trans Am  (Read 5610 times)

0 Members and 1 Guest are viewing this topic.

rangernut09011980

  • Message Board Member but not a NFTAC Club Member
  • *
  • Posts: 5
Couple of WEIRD problems 1984 WS6 Trans Am
« on: November 16, 2009, 10:32:51 PM »
Hey all I am glad I stumbled across this site I have a few electrical problems with my 1984 WS6 TTop


The first Electrical problem started while it was still running(and drivable)   

 ??? ??? I have zero Instrumentation beyond the fuel gauge and the Speedo, the Tach reads 3k all the time(running or not)  and nothing else works for gauges I have checked all of the fuses and all test good and i have also check for pinched wires (engine was missing when I bought the car I installed a 1993 5.7ltr centerbolt engine from 1993 GMC van) around the bellhousing, I can find nothing that Seems out of place All gagues were working fine and then this started rather suddenly  I am at a loss as to what the problem could be  and was wondering if somebody else has experienced this with theirs ??? ???

Transmission died 1 month after I installed engine(it works for approx 100 yards and then it acts like the trans is not even there) I am gonna replace the fluid and filter and see if that helps if it don't I will have to have it rebuilt

Electrical Problem 2 started After car sat for approx 1 year 

 ??? ??? I used to start it regularly every few weeks or so to keep things lubed and to keep engine from seizing (this problem is in the starting circuit somewhere) and I had no problems until 1 day I went out to start it  and I have no power going to the starter when I turn the key to the start position I have used a screwdriver and can jump the terminals on the starter and it works fine so I KNOW the starter is not the problem  I am leaning towards the possibility of maybe the Starter switch on the steering column has gone bad but would like to get some input b4 I start Dissecting this car  ??? ???

Thanks in advance  Rangernut

PS I am also a PONTIAC FANATIC

rangernut09011980

  • Message Board Member but not a NFTAC Club Member
  • *
  • Posts: 5
Re: Couple of WEIRD problems 1984 WS6 Trans Am
« Reply #1 on: November 19, 2009, 01:01:13 AM »
Come on guys I need some input on these issues........ :-\

gorin002

  • Firebird & Trans Am Club Member
  • ***
  • Posts: 340
Re: Couple of WEIRD problems 1984 WS6 Trans Am
« Reply #2 on: November 21, 2009, 02:20:26 PM »
i am truly sory i can t help you :'(
i hope guys here can i can t :(

ThunderChicken

  • Firebird & Trans Am Club Member
  • ***
  • Posts: 201
  • It's a sickness...
    • Firebird Fest of the Carolinas
Re: Couple of WEIRD problems 1984 WS6 Trans Am
« Reply #3 on: January 30, 2010, 10:41:36 AM »
LT1-style engines are NOTORIOUS for burning through one of the plug wires on one of the rear cylinders.  Make sure you have looms on all the wiring.  If you have a test light and a multimeter, those are going to be your best friends.
Bethany
1988 Flame Red GTA, 305 TPI--Bone stock heart, Flowmaster exhaust, Wonderbar coming soon!
1995 Medium Teal Blue Metallic V6 Firebird

Stock(ish) 1983 Black and Gold T/A, Edelbrock 600 Carb, Performer 2101 Intake-SOLD

gorin002

  • Firebird & Trans Am Club Member
  • ***
  • Posts: 340
Re: Couple of WEIRD problems 1984 WS6 Trans Am
« Reply #4 on: February 12, 2010, 01:22:43 PM »
and ?

National Firebird and Trans Am Club Message Board

Re: Couple of WEIRD problems 1984 WS6 Trans Am
« Reply #4 on: February 12, 2010, 01:22:43 PM »


 

NFTAC website home page or NFTAC Photo Gallery or NFTAC Club Blog